Neo Geo CD – CSYNC questions

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support Neo Geo CD – CSYNC questions

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • #21827
    cheeseman
    Participant

    Hi there,

    Picked up a neo geo cd toploader and had some general questions about it interacting with the OSSC.

    Turns out the Neo Geo CD’s right from the factory do not have the CSYNC pin connected to the multi out. I’ve down the following mod:

    NGCD CSYNC

    I’m still waiting for my CSYNC cable to show up from retrogamingcables (UK) and they also mentioned to go ahead with the mod.

    Apparently, much like the Sega Genesis CSYNC, the voltage on this will be TTL (which I think is 5V?) and in most cases a 470 Ohm resistor is used to bring down the voltage to 3.35v (or close to that value)

    I”m just wondering if any of this would be a concern for the OSSC – would the 5v be dangerous to the OSSC, should I toss on a resistor if it’s not already on the CSYNC cable itself?

    Thanks, just don’t want to fry my OSSC – love it.

    #21832
    BuckoA51
    Keymaster

    Yes, using the resistor is highly recommended. Unlikely that you’d fry your unit feeding it TTL but it’s somewhat out of spec and could cause damage over time.

    #21857
    NoAffinity
    Participant

    I’m curious – it looks like the audio is routed via RCA cables, and not going through the SCART connector? How will you handle the audio transmission?

    #21859
    nmalinoski
    Participant

    You should be able to get sync normally from composite or luma, right?

    Audio can be added into SCART with an injector/breakout shim, assuming it’s fully wired, or can be routed around the OSSC (which would be necessary for <=1.5 OSSCs anyway.

    #21866
    cheeseman
    Participant

    There is actually a CSYNC scart cable at retrogamingcables (UK) that is wired up with the L/R RCA jacks:

    https://www.retrogamingcables.co.uk/neo-geo/snk-neo-geo-cd-cdz-rgb-scart-cable-stereo-sound

    This will route the audio right to the scart connector. I think you might be able to get MONO out of the same A/V port as the RGB with a different cable.

    I run the Otaku 6 port Scart Switch (which has been awesome despite what I read about it online), I used to daisy chain x2 Hama Scart 3 port switches for a total of 5, but there was alot of noise and other video artifacts for every system I had.

    Basically off my 6 retro systems, I either have breakout cables to separate the audio from any video right from the system (or the system has built in RCA audio out) which then goes to an 8 port RCA Switcher to my Receiver.

    The OSSC was also pass it along just fine, but for my unit would add some noise and will randomly drop the audio of any game and any system for 5-15 seconds randomly. Though it’s actually been fine recently.

    #21937
    cheeseman
    Participant

    Hey guys,

    Things have taken a strange turn.

    My RetroGaming Csync Scart cable showed up today. I get nothing from the OSSC. Just says no sync.

    Prior to trying out the cables, I put on a 470 ohm resistor on the CSYNC line while I did the mod linked above to the Neo Geo mother/daughterboard.

    Thinking I may of botched the mod, i rolled it back (it’s easy enough) and yet again, still nothing.

    Maybe it’s the cable or the port?? I have no idea because Audio still works as does the Yellow RCA jack (composite) and the S-video cable.

    Luke Morris had a video on youtube, where some Inductors that looked like resistors had died on the board, but that killed all the video out puts and mine seem to be okay so I am somewhat lost as what to try next.

    Any help or ideas would be greatly appreciated. I have a cap kit on the way, but will be a few weeks. I’ve also ordered a normal cable for that port that just has a yellow and white RCA. (to help rule out anything)

    #21950
    NoAffinity
    Participant

    Looking at the mod instructions, my mind immediately goes to the part about cutting traces. You probably already have, but the first place I would look is making sure only the traces that are supposed to be cut have been cut, and that the cut traces are completely severed. Mutlimeter continuity check on the cut lines to make sure there is no continuity, and multimeter check on any nearby lines to make sure they still have continuity.

    #21951
    cheeseman
    Participant

    The good thing about this board, is as far as I can tell there are no other traces on the other side of the board. (there are some caps in the way)

    I think you are right though – something just isn’t hooked up/bridged. The face that composite and s-video work means it can output video/Sync

    See below for a link – this is what i rigged up for testing I”ll clean it up a bit better once i get it working. (also the resistor is in the electrical tape)

    CSYNC MMOD

    I checked the continuity, and the traces are cut properly. The Yellow wire is the sync on composite signal and it runs all the way to the yellow RCA without issue. (even after this mod the audio and other video outputs work)

    The black wire (CSync) I can trace right from the start (from the video encoder) right to the AV Port. Not sure what pin it’s supposed to go through, but I can check when I get home if someone can confirm.

    Also I reflowed the solder on the AV out, just in case that was it.

    #21955
    NoAffinity
    Participant

    Check for continuity between the pin with white wire/black tape to each of the pins with the yellow wire bridge? (Probably implied that you already did, but just double checking) Also, check for continuity from each of the 3 pins to ground?

    Csync should go to SCART pin 20. But, you won’t get continuity from end to end if there are resistors, caps, etc along the path. You may have to open visually trace it out.

    #21964
    cheeseman
    Participant

    -Always good to double check and sorry for this wall of text:

    It’s good in the sense that continuity is not overlapping (Composite Sync Yellow is not touching the White CSYNC/Resistor wire at all)

    I also can confirm the CSYNC Scart Cable is wired from pin 20 to Din 7 with continuity. It is not wired to Composite Video Pin 3 Din.

    However, only the CSYNC/Resistor/White wire will have continuity with the ground. The x2 pins the yellow wire is connected to doesn’t reach the ground, but that out put seems to be working just fine – see below

    I found an old Sega Model 1 A/V -> Yellow and White RCA out… Plugged that in for kicks and it works! Mono sound and Composite video no problem.

    This connector only uses the following pins = 1-5 (basically just the U shape)
    So it’s Missing 6-8 (CSYNC, Blue and Red)

    Not sure if any of that helps or we can safely assuming pins 1-5 of the DIN are okay.

    #21970
    cheeseman
    Participant

    Something else I just tried:

    I remember hearing that the Neo Geo Ouputs video through all the ports at once.

    I can output video via the Yellow RCA and the AV/ Yellow RCA at the same time NP.

    If I use my scart cable, the yellow RCA goes B/W and the sync is out of whack (vertical and horizontal scrolling)

    Also updated my OSSC from .80 to .81

    #21974
    paulb_nl
    Participant

    However, only the CSYNC/Resistor/White wire will have continuity with the ground.

    CSYNC should not have continuity to ground (when the RGB cable not connected). Redo the mod until its not shorted to ground.

    #21977
    cheeseman
    Participant

    Awesome, thanks for that info! (Makes sense as the sync on composite doesn’t have continuity and it works)

    I double checked the mod and I don’t see how I could of introduced the short. See below for my continuity findings.

    Just a heads up, I removed the resistor for the CSYNC for these tests. The Yellow stars have continuity while the Red don’t.

    check 1

    Since the CSYNC line was still reading as connected to the ground, I took the whole white wire off, so i could test it at the chip and the DIN pin:

    check2

    Not sure if there should be continuity on the chip between Sync and ground but there is, while the CSYNC pin on the DIN is completely isolated from the ground and the composite sync unless I connect it to the encoder chip.

    Maybe i’m testing this wrong? Bad chip?

    Thanks for all the replies – closing in on the issue.

    #21984
    paulb_nl
    Participant

    So with CSYNC continuity to ground you mean 0 Ohm resistance right?

    To make sure the CSYNC RGB cable actually works, try bridging the CSYNC pin you cut back to the composite video pin to see if you get sync with the OSSC.

    #21985
    cheeseman
    Participant

    I was using the continuity checker on my multimeter. It beeps if there is continuity.

    If I set it for Ohm’s there is nothing between the CSYNC line and the ground.

    I had rolled back to composite/revered mod before, but just did it again and… no sync.

    Something else random – I just tried using the sync on Luma from the S-Video port to the CSync Pin on the din and same thing no sync.

    Bad Cable? Some sort if setting I need to tweak in the OSSC?

Viewing 15 posts - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.