Sound drop : sync issue, TV issue?

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support Sound drop : sync issue, TV issue?

Viewing 12 posts - 16 through 27 (of 27 total)
  • Author
    Posts
  • #38540
    Fed
    Participant

    I was not able to reproduce the issue using a CRU profile with the attributes you provided… but they do make me question something… why have an horizontal active set to 1440 since running 480px2 mode through the OSSC results in a 1280 horizontal resolution on the TV ?

    #38568
    marqs
    Participant

    Yout TV reports horizontal 1280px resolution when using OSSC with 480p AV1/AV2 input and 480p sampler set to “Auto” or “DTV 480p”? Did your TV then report the same as well with the 1440×960 CRU mode?

    #38571
    Fed
    Participant

    I have tested with both VGA and SCART inputs using a Dreamcast. When using SCART input I am using a retrogamingcables UK RGB Scart set to 480p mode.
    Auto, DTV 480p and VESA 640×480@60 are all reported as 1280×960/60Hz by the TV when using an H. active value of 640 and V. active 480.
    DTV 480p does output in correct 4:3 format vs the narrower VESA 640×480@60 but reported resolution by TV is identical.
    Increasing the H. active value to 687 on the OSSC using DTV 480p I am able to more the TV resolution up to 1374×960. Pushing the value beyond 687 does not cause the resolution to increase any further. (Not sure if this helps in any way but wanted to share just in case)

    TV reports 1440×960/60hz when using the CRU “profile” you provided.
    Another way to get 1440×960/60Hz on the TV is through 480i source as it can be seen here and this also results in sound drops. But as I stated earlier 480p sources result in 1280×960/60Hz.

    Also wanted to reiterate that irrespective of the line multiplication and resolution output the sound drop can be constantly reproduced when H. Samplerate is of 858… my gut feeling is that troubleshooting should be focused around that point but my poor knowledge does not allow me to make any suggestion on what to look into exactly.

    #38579
    marqs
    Participant

    Can you try this test image? It has IT6613E audio full packet mode enabled – I have a faint recollection that this caused issues in some setup but it’s worth trying if it’d help here.

    #38587
    Fed
    Participant

    Gave it a try but the problem remains sadly.
    In my opinion the problem is not coming from the audio data… if something was problematic with how the audio was sent to the TV the problem would be reproducible irrespective of what video settings are being used.
    What we are observing here is that as soon as the H. samplerate is set to 858 the TV starts having problems with the incoming signal so for me the questions remains, why are Sony 4k TVs having difficulties with this particular H. samplerate value ? There is something the TV does not like about it but what ?

    #38589
    marqs
    Participant

    858 is the standard Htotal for 480p so it’s hard to understand why that would specifically cause problems. In that case you should be able to replicate the issue using the test pattern (which is 480p). To get audio playing on test pattern, connect some audio source to one of the 3.5mm plugs or SCART (without video), then select respective AV input and toggle TX mode to DVI and back to HDMI.

    To answer your earlier question on 1440px width, I meant using the DTV mode with default sampling settings (720 H.active). That should be identified by 1440×960 by the TV like with that CRU mode or in the video on the thread you linked.

    #38592
    Fed
    Participant

    You are right, the problem actually only occurs when we have a combination of 480px2, 858 and TX Mode HDMI (problem disappears when using DVI obviously), not simply when using 858. Here is my report posted back in March on GitHub issue #34 :

    I would like to report I am experiencing the same audio cuts problem reported here running fw 0.85a.
    More specifically when using 480p x2 with H.Samplerate value of 858.00, let me explain :

    If I switch to 480p passthru (still maintaining H.Samplerate value of 858.00) audio works perfectly fine.
    If I stay in 480p x2 mode and change the H.Samplerate value by a few units, audio works perfectly fine but then obviously I get a blurry signal.
    If I stay in 480p x2 mode and enable Allowupsample2x then change the H. Samplerate value to 857.95 or 858.25 audio works fine.
    Tested on both AV1 and AV3 inputs.

    I like your idea of the using the test pattern but it seems it is not possible to set it to 480px2.

    Regarding my previous statement of not being able to get 1440px width I found out that it was because of my particular Adv. timing settings. When I used the test image you provided that had default Adv. timing settings 480px2 was effectively identified as 1440px by the TV, apologies for the confusion caused by this.

    Let me know if you have any other suggestions I could try to hopefully identify the root cause of this issue. For the time being I will happily continue playing the audio out of the OSSC through some external speakers rather than through HDMI.
    Once again kiitos for taking the time to look into this particular issue, it is a true pleasure to be able to directly converse with you on this hardware gem you created.

    #47772
    Steg2021
    Participant

    Had the exact same issue with a new Dreamcast VGA cable and 480p x2. Changing the H.samplerate to 859 sorted the audio drops on my Sony TV and the annoying banner popping up so thanks for the tip. Not really sure what this has changed as the picture looks identical and can’t see any blurryness so far. How can I check to see what this has actually done to the image ?

    #47778
    Fed
    Participant

    If you bring up the checkerboard pattern in the 240p test suite you will sadly notice that part of your picture is now blurry.

    #47781
    Steg2021
    Participant

    I tried switching TX mode to DVI and bypass the OSSC for sound and plug the audio jack straight into my amp, seems fine in this mode so far. Megadrive seems fine in 5x mode and RGB scart, haven’t tried anything else yet though.

    #47789
    Fed
    Participant

    Yep, DVI mode is the only workaround without compromising video quality.

    #49078
    Fed
    Participant

    FYI this problem has disappeared for me using a Retrotink 5x

Viewing 12 posts - 16 through 27 (of 27 total)
  • You must be logged in to reply to this topic.