Voultar's RGB Bypass (8 consoles dead)

NewHome Forums Repairs and Mods Voultar's RGB Bypass (8 consoles dead)

Tagged: 

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #27005
    BlueStinger
    Participant

    I’m not mad, try to read this while picturing me curious rather than upset.

    I’ll try to boil it down because it’s a month and a half journey for me, 8 consoles died, 500 or £600 lost…

    I’ve “successfully” installed Voultar’s RGB Bypass board, great picture (although not all consoles are made equal apaprently), I’ve seen it work, sometimes for days but all the consoles ended up dying. Some of them had Voultar’s board only, some of them had Voultar’s board + Mini Mega, others had Voultar’s board + switchless 50/60Hz mod.

    There’s a point to be made here : All dead consoles only had a handful of things in common :
    – Me, the average modder trying its best
    – The power supply units (or rather the electricity in my house, I used 5 different PSUs)
    – Voultar’s board

    Granted, I’m not the best modder in town but I took a picture of one of my installs so you know we’re not talking about a rookie mistake here (like “you forgot to turn it on”) : https://imgur.com/gallery/GuvFmhG

    I blamed myself for weeks (still do), then blamed the power supply units, I’ve read everything the internet has to offer when it comes to Megadrive RGB Bypass and the lack of people claiming that they have successfully installed it (on PAL consoles) started to make me think that maybe the bypass board itself was the issue, somehow. I’m not blaming it, it’s just that my last two remaining theories are :
    – Me, staring at a PAL Megadrive automatically kills it (some sort of obnoxious superpower)
    – The electricity in my house is special (PAL consoles, I’m in UK, should be good)

    Of course I’ve seen people claiming they did it, and I thought I did it too. For all those who think that they’ve successfully installed it, here’s my questions for you : Have you tried playing it for 2 hours straight ? And right after tried another game ? Because all my Megadrives were seemingly fine, I’ve even sold 2 of them (£280 loss right there…), but if you extend your testing, I’m willing to bet that some of the people who claim to have succeeded simply don’t know yet that that they failed. No offense but I’ve seen multiple people with very clean install basically telling what I’m telling you now. It’s just that I happen to have 8 examples ^-^

    So, 8 consoles dead later, here are the symptoms (one symptom per console basically, if I re-install the mod, a different symptom can pop up) :
    – Runs fine for 2 hours, if you change the game or power cycle it, it won’t run anymore. Wait 5 or 10 minutes and it can run for 2 hours again.
    – OSSC can’t get Sync, other TVs will but it’ll be messed up (swinging left and right for instance, sometimes it’s fine for a while…)
    – Will work for a while, at one point you can’t go past TMSS screen and then black screen forever
    – Weird color issues (my customer had an ‘all red screen’ and I had a yellow tint when he returned it to me)
    And I’ve probably forgot some of them.

    Bear in mind that I’ve spent a month and a half working almost exclusively on Meagdrives, I’ve read everything I could, can’t find a solution to my issue. I had 8 consoles and many RGB bypass board (all purchase on VGP.com, nothing sketchy), I performed way more than 8 installs, I worked a month and a half on those 8 consoles basically so I’ve installed the mod countless times (always work at first by the way).

    Here’s how I installed some of the Voultar’s boards (I tried several ways, it doesn’t matter really, results are the same):
    – Clean the console, reflow pins, change voltage regulators, remove RF mod, blablabla the usual stuff
    – Lift R,G,B and Csync from the VDP (short wires directly to the RGB bypass)
    – Lift or cut the pins on the CXA (RGB and Csync)
    – Get +5v and GND from voltage regulator (cables twisted to reduce interference, voltage regulator gives a clean 5V)
    – Feed Csync to the pin of the DIN (top side)
    – Feed R, G and B to AV connector pin (bottom side)
    And that’s it, it’s a simple and straight forward mod really. The simple fact of doing what’s listed above basically was a death sentence.

    All consoles were PAL and I had multiple revisions, some with TMSS and some without. I had multiple games to try and an OSSC as well as a random TV with a SCART connector.

    Keep this in mind : I’ve successfully installed this mod multiple times, I’ve seen jailbar-free Megadrive, the consoles appeared to be fine for a while, I’ve even sold 2 of them (which were obviously returned and refunded). I’m NOT asking how to perform this mod.

    Basically, I’m asking : What is going on here ?!

    With what happened to me and the fact that I’ve seen way more people having the same issues that I had than people who claim to have successfully modded one makes me think something is wrong here. Just type “VGP Rgb Bypass” on Google and you’ll see, a ton of questions, no clear answer. As if no one knows what’s going on.

    Is there even anyone who have successfully installed an RGB Bypass (V2) in a PAL Megadrive ? And more important : Does it still work ?!

    Also, I’ve seen the diagram of the RGB amp in Voultar’s board, I don’t even know how this board could kill a console even with a bad intent ^-^ I’m just puzzled. I gave up already, I’ll come back to those 8 consoles later, even maybe next year. But I had to ask ! This thing is an enigma, it kills me from the inside !

    Sorry for the long post and sorry if you’re now afraid of installing an RGB Bypass in your console because you’ve read this… Just try one console at a time, don’t be like me =)

    #27056
    renovigo
    Participant

    Hi,

    I encountered that kind of problem on a pal va4 megadrive with rgb bypass installed as you did AND the CXA video amp removed. I saw on your picture that the CXA is removed too am I right ? If so, try to put it back. It seems that some people had the same problem of a machine working for 2 hours and then won’t boot anymore. It’s linked to the missed CXA. This chip seems to do more than video amplify (maybe a clock relation).

    The consoles are not dead I’m pretty sure about it.

    Try to put the CXA first and then see.

    Best

    #27058
    BlueStinger
    Participant

    Thanks for helping ! I tried that, it didn’t do any good. basically I tried all these :
    – following the “official” instructions (not lifting pins, cutting traces under the board etc)
    – lifting pins and feeding them to the CXA pins (with the CXA still in place)
    – lifting pins and removing the CXA entirely
    – lifting pins but NOT Csync, leaving CXA in place
    – putting CXA back in (at least 2 consoles)
    – reverting one of the consoles back to stock

    none of these worked. Yes, including the last one. From my point of view (not saying that’s the case), as soon as install an RGB bypass, it’s a death sentence

    #27059
    renovigo
    Participant

    Hi,

    I’m sorry to hear you’re still in trouble with these.
    Well, I’m looking at your picture, and here’s what I would do, just for trying (in that order) :

    – put the CXA back (I understand you’ve already did that).
    – connecting the mini mega to different +5 and grd points ( a capacitor would be fine).
    – disconnect the switchless board and try without it, just to see.
    – check for false contacts on the VDP, could be a little solder which leaked to a pin beside another one.
    – with all these mods, you can try to use a power brick with 9V and at least 2A (I use one with 2,5A).
    – recapping the system with new capacitors + new voltage regulators (last thing to do because it’s quite long).

    Honestly, I would find it very strange that an rgb bypass amp kills an entire system, because it’s just dealing with video and nothing else. But I know that the more you add mods on a megadrive, the more you expose yourself to risks of interferences between them, and sometimes it could be a tiny thing to change to get everything sorted out. But I understand it could be a pain in the back sometimes.

    Please let us know about you’re investigations.

    Best

    #27060
    renovigo
    Participant

    Didn’t ask before or maybe you’ve already mentionned it, but do you hear any sound when you put on the machine ? Because I see on your picture that the mini mega is not plugged into outlines, and it would be interesting to know if you get some sound.

    #27061
    BlueStinger
    Participant

    That’s the thing though, there are Mini Mega in only 2 of the 8 consoles, same for the switchless board, it’s only some consoles, not all. Iv’e also removed them and try without them, they are clearly not the culprit. The picture is just an example of one install. I gave the picture to show that I’m a least not the worst modder out there. I checked with a magnifying glass (a pretty “powerful” one) and I can’t find any solder bridge (continuity tests are fine too).

    I used 5 power supplies in total :
    – This one : https://en.retrogamesupply.com/collections/sega/products/power-supply-for-sega-megadrive-genesis-1
    – 2x official MD1/Genesis PSUs (I think both have a dead cap as I had a random reset issue with both)
    – 2x official Master System 2 PSUs (both work fine whether it’s with SMS2 or MD1/Gen)

    Though you brought a very good point, I guess I checked already but I don’t remember the result I got, I’ll try the ones with Mini Mega to see if there is sound

    #27062
    renovigo
    Participant

    That’s very strange…Maybe try a more powerful amperage PSU like I said before, just to check. I know it’s not a big difference but it worth the try.

    If the continuity test says there’s still power getting through the machine, I guess there’s still hope.

    Maybe check the CXA again for simple things like to see if it’s not upside-down, or if all the pins a well soldered to the board, or if there’s no little solder blob around it on the board.

    #27063
    BlueStinger
    Participant

    I’ll check all that (I’m already sure that everything is good but I always blame the modder before the hardware), I need to finish the Saturn and the SEGA CDX I’m working on and I’ll take a good look.

    #27103
    RetroRGB
    Participant

    With respect, it sounds like:

    – One of the PSU’s is bad and as soon as you try it, it kills the Genesis. Take one of the official PSU’s, replace the capacitor and check it on a multi-meter to make sure it’s outputting proper voltage. Then ONLY use that PSU.

    – You need to leave the CXA’s in and only lift RGBs out. Removing the CXA will cause the Z80 to loose timing after like 20 min. We haven’t researched other ways to fix this yet, as leaving the CXA in doesn’t add any interference.

    – Maybe the two other boards are interfering?

    – I doubt the 7805’s are dead in all consoles (unless maybe the PSU killed them?), but it wouldn’t hurt to try replacing those as well.

    Other than that, I’ve tested at least 50 consoles with either the Voultar board or Triple Bypass (3BP) and all are still working flawlessly.

    #27104
    BlueStinger
    Participant

    Hey Bob !!! Big fan of yours, haven’t miss a single one of your videos !
    – Voltage regulators have been replaced (with both 1A or 1.5A), they all output around 5V
    – I’ve re-soldered the CXA in some, didn’t remove it in others, didn’t do any good
    – “other boards interfering” some of the consoles only had an RGB Bypass
    – I’m in PAL territory
    – My customers were both using official PSUs (and I’m using an official Master System PSU that doesn’t cause any issue with the SMS)

    I’ll get one out this afternoon, make sure I check every box you mentioned. Even though I’m sure at least one of them already does.
    I’ll also post as many pictures as I can.

    #27107
    BlueStinger
    Participant

    here are some pictures :

    MD1 PAL RGB Bypass

    There are 2 boards there, unfortunately it’s hard to tell which one is which on picture. Pretty obvious irl.
    The one with only an RGB bypass seems to work fine but I haven’t tested it more than 40 minutes. (this one has a nasty RAM noise)

    The other one has a perfect picture, but it shifts from left to right like crazy. I’ve disconnected the 5V from the Mini Mega but it didn’t do any good. My other TV doesn’t accept the signal, my ossc either.

    #27140
    BuckoA51
    Keymaster

    CXA must stay on the board as it buffers the audio, do not remove it.

    We’ve installed the bypass on PAL consoles and apart from issues with sync (now resolved) it’s worked just fine including for extended sessions.

    #27142
    BlueStinger
    Participant

    And apparently, it should stay no matter what because I was using a Mini Mega… Although maybe the Mini Mega doesn’t bypass CXA ? Not sure, I’ve never had any issue with the Mini Mega so I haven’t looked into it. Anyway, CXA should remain on PAL consoles. I get that… now ^-^

    #27146
    BuckoA51
    Keymaster

    Do not remove CXA on ANY model.

    #47646
    nzChris
    Participant

    @bluestinger did you ever find a resolution to this? I installed on a few UK consoles also around two years back and had the same issues with OSSC loosing sync and the red light popping up till I restart the console. I also had sold one and had it returned which was terrible.

Viewing 15 posts - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.