Tips & Tweaks: Lx3, Lx4, Lx5 modes

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support Tips & Tweaks: Lx3, Lx4, Lx5 modes

Viewing 15 posts - 136 through 150 (of 168 total)
  • Author
  • #23879

    Yep, and my (and everyone elses)$1000 Sony Bravia is still stuck at 2x.


    No luck unfortunately.

    Even with generic 4:3 mode on I can’t get a picture on 1600×1200 or 1920×1080. Oddly 320×240 at 1920×1200 is the only one that seems to work in that generic mode. I think I’ll call it a day until I get my RGB bypass installed.

    While I’m a little disappointed my Sony kd55x8500c has been fairly forgiving with what the OSSC throws at it, considering it was a blind buy on sale well before I picked up my unit.


    Same here. Fortunately Sony TVs are good at other things!


    That’s the unfortunate thing that even the Panasonic OLED TV’s are just as bad as mine for OSSC compatibility. I like the TV though so it’s such a shame in a way.

    I’ll have a look at that tomorrow but in generic 4:3 you might get away with H Active 1920 and H Samplerate 2200 or higher to correct the aspect. You should get a picture at 2200 though. That should at least work for 1920×1080 but you’re going to lose a lot of vertical detail.


    I think the problem with 320×240 optimized in 5x is that exceeds some max pixel clock limitation of what the display can handle. My Philips TV behaves the same.
    Generic mode 5x has h.samplerate of 2046 (actually this is the same as 256×240 optimized 4:3: 341×6 = 2046). With a NES/SNES (262 lines) the pixel clock is roughly 160.8 MHz.
    Optimized 320×240 has total output samplerate of above 2100 (e.g. 427×5 = 2135). With a MD/Genesis (263 lines) the pixel clock is roughly 168.4 MHz. Somewhere in that territory is where my display will not accept the signal anymore.
    (Keep in mind that the standard pixel clock for 1080p is 148.5 MHz, and for WUXGA (1920×1200@60Hz) it’s 153.9 MHz, so we are already above those from the beginning.)

    Regarding your PAL 1080p 4x tweak, I can add that while the 2200 samplerate/1920 active setting does indeed work on my TV, it prevents me from forcing 4:3 so I get wrong AR. So I tweaked it back to a 4:3 format by h.samplerate at 1938 with 1440 (sync/backporch roughly 170/210). My TV recognizes this as a 1440×1080 @ 50Hz signal and displays it beautifully.


    Nice find. That’s the exact problem I expected some people to run into with the forced aspect ratio. For the displays that will accept 1440×1080, that’s pretty much perfection for PAL. Samsung TV’s can force 4:3 so the 2200 H Samplerate / 1920 Active way works on those.

    For the sake of it though, I’ll try it the 1938 / 1440 on the little Samsung TV I have.

    EDIT: I just get mode not supported on the Samsung, but the good thing is that since it allows 4:3 it works fine with 2460 / 1920 🙂

    UPDATE: It seems my 22″ Samsung TV (UE22D5003BW) reacts very oddly to 480p x2. If I switch to it from passthrough, then the TV reports 1440×900 but the image is way too big, but then when I power cycle the TV with it still on x2, the entire 1440×960 window is on screen and scaled full size while the TV still seems to report 1440×900. I mean I’m happy that it works on it, but it behaves so strangely.



    Thanks for your explanation, that more or less clears up why 5x works without issue on 240 optim on my set but 320 causes so many issues. As I said earlier I really lucked out with my 8500c since it has no problems with 2x and 4x so I shouldn’t be too discouraged by the issues with 5x for my Megadrive.


    Just wondering, has anyone that is stuck in Lx2 that uses NTSC consoles ever tried doing either of these tweaks to get Lx3 in generic 4:3 (assuming the tweaks on page 1 and the 1366×768 tweak marqs shared don’t work for you)?

    I’m just wondering since almost every TV supports 1024×768 and this seems to work on my very fussy Panasonic TV. The only downside is the picture will be shifted to the right, but it would sure beat Lx2.

    Decrease H. Active to 768, increase V. Active to 256, decrease H. Samplerate to 981, increase H. Synclen to 61 and then finally, decrease V. Backporch until you get an image.

    The other way is if your TV supports 1280×768 like mine seems to, and if the tweak on the first page doesn’t seem to work for you.

    Basically, this one is the same trick for 3x that’s already listed on the first page, except first you increase H. Samplerate to 1221 and H. Synclen to 100, then do the same as the rest of the tweak (increase V. Active to 256 and decrease V. Backporch until you get an image).

    Again, I’m not sure if these have already been mentioned, but I figured those out by messing about on my really fussy Panasonic TV.

    Also, I’m seeing people with TV’s like Bravia’s that support these resolutions, including 1360×768 saying they’re stuck in Lx2. For 1360×768, try increasing H. Active to 1020, V. Active to 256, H. samplerate to 1320, H. Synclen to 110 and then decrease V. Backporch until you get an image (about 2). Technically this should work and the TV should pick it up as 1360×768.


    It’s me again guys!,

    Just looking for some help with PS1 Optimal timings; through 240p test suite I have been able to get some pretty good results on my KDLx8500c with 340×240 (line 4x), 384×240 (line 4x) and 256×240 (line 5x). I have been using the optimal timings found at Junkerhq however, I can’t for the life of me get 512×240 to output a clean picture, no amount of sample phase adjustment or H samplerate tinkering seems to be able to clear up the noisy vertical bars in the picture.

    Anyway I’d really appreciate some help as I wasted quite a few hours getting nowhere this afternoon.

    The games are running through my PS2 via OEM component cables, but I can try my RGC RGB cable if anyone thinks it would help.

    So, it turns out I made a few rookie errors in the web app while planning my profiles that I didn’t catch until now. Now everything looks great at 512×240 at line 4x!, however the aspect ratio is 8:7 is there a way to correct this to 4:3?, my 8500c doesn’t really have any scaling options other than to scale proportionally to height or force 16:9.


    512×240 can only do 8:7 aspect because it can only double on the horizontal, not x2.5 which would be the equivalent to 256×240 x4 mode (x5 horizontally in 4:3 mode).
    Theoretically i guess it could do x3 horizontally, but that is really too wide to resemble 4:3.


    Good evening friends.
    My retro computer has 300 visible lines. Using the increase in the value of the V.Active parameter, I was able to achieve a display of 297 lines. Setting the values 298-300 changes nothing and 3 lines of the image are lost. What can be done?


    The result of further testing OSSC + retrocomputer Soyuz-Neon. Immediately make a reservation: the experiments showed that in the existing software of this computer, all 300 lines are actively used for graphics !!!

    I have the usual 22-inch widescreen Dell 1920*1080, on which I began to conduct experiments.
    Having tried all the combinations of parameters, I selected the optimal (V.Active = 297, V.backporch = 6, V.synclen = 4) at which the topmost (first) line of the Soyuz-Neon computer image coincides with the top line of the monitor matrix, and the screen displays 297 lines of the original image of the computer Soyuz-Neon:
    At the same time, in the menu of the monitor, the current resolution is displayed as 710×594. Accordingly, the 3 lower lines of the original signal are lost, and when trying to increase V.Active = 297 -> 298 and higher, the image disappears for good, because the monitor cannot enter this mode.

    Earlier, as an alternative to a PVM TV, I purchased a Sony LMD-1510W monitor, which turned up useless in terms of trying to connect to it the RGBS signal of any retro console. Unexpectedly, the HDMI input of this monitor opened up unprecedented multi-format capabilities, starting with the fact that the HDMI output of the OSSC, brought to it, was recognized as 576i and ending with the fact that the video stream of 301 lines, processed inside OSSC using a 3x multiplier, was recognized on my monitor as the resolution 1NNNx903 – This is despite the fact that the limit resolution of the monitor is 1366×768. NNN in this case changes arbitrarily in direct proportion to the value of the parameter H.samplerate set in OSSC, and, according to my observations, H.samplerate does not significantly affect the final result. For Lx3 mode, the output format was 16: 9, which was interpreted by the multiplier as 1280×288, where 301 multiplied by 3 was used as 288 lines.
    Thus, by setting the parameters (V.Active = 301, V.backporch = 6, V.synclen = 4) + Lx3 (16:9) I received all 300 lines of the Soyuz-Neon computer image on the Sony LMD-1510W monitor:

    1). OSSC is a very, very interesting product, I hope the firmware will still be actively developed.
    2). Since OSSC, unlike framemeister, is a multiplier, not a scaler, in order to provide better image clarity, you need to use the highest multiplication factor (Lx3, Lx4, Lx5). Accordingly, to use at least Lx4 mode, you will need a monitor that can display 1200 lines vertically. When complying with the FullHD / IPS criteria, the cheapest option is Iiyama ProLite XU2395WSU-1
    3). The selected monitor should be as flexible as possible in terms of multi-format signal, otherwise it simply does not recognize most of the modes issued by OSSC.

    Resume: I leave to myself OSSC, because besides the framemeister, this is the only decent and versatile upscaler that can also be bought 2 times cheaper.

    My questions:
    – Is there complete documentation for OSSC, which describes the purpose of each parameter, as well as a list of supported output resolutions for each of the Lx2 .. Lx5 multipliers?
    – What affects the parameter H.samplerate and on the basis of which is the value calculated in which it should be set?
    – What monitor needs to be purchased so that 300 lines of the original image fit on it when using the Lx5 multiplier? The fact is that I have enough of the image clarity that the Lx4 mode gives.


    Hi there, I’m here losing my head with OSSC and my PS1 again x’D

    Today I just tried a utility called “ImportPlayer Light v2.1” for my PAL PS1 to force NTSC video mode in it, resulting on having my spanish PAL game working at 59,27Hz instead of 49,76Hz!

    As I posted here before, in PAL mode the Lx5 line mode didn’t worked for me, but now works (all messy), so I decided to go Lx4 anyway since it looks so good and the boot screen for the boot utility CD doesn’t work in Lx5 either.

    Okay so now I’m at Lx4 mode, 314p and 1280×240 mode. The screen looks stretched but vertically! And there are things that are showed in screen (cause the Tomb Raider 2 game has an option to move/place the screen and the screen seems to continue all the way down) but I can’t figure out how to stretch the image vertically…
    If I increase the vertical active number over 243 it makes nothing, and if I decrease it below that only get worse…

    What can I do?


    Actual settings under 1280×240 are:
    H Samplerate: 1618
    H Synclen: 72
    H Backporch: 170
    H Active: 1328
    V Synclen: 7 (can’t go over this value)
    V Backporch: 32
    V Active: 223

    My TV is a Samsung QLED in 4:3 mode, since I observed that in NTSC video mode only offers my 16:9 or 4:3, avoiding the custom zoom option I sometimes use…


    If it’s 314 lines, it’s still in PAL mode.
    I do not know if a PS1 can have more than 240 active vertical lines, in any mode. PS1 can utilize many different output resolutions, while some games do have 224 vertical, the majority has 240, so you should keep V.Active at 240, at least for NTSC mode.

    I think you will have an easier time if you get the 240p test suite, much easier to keep track of things.
    (.bin/.cue files are in the binary folder)


    Works beautifully in x2 mode, but getting nothing with x3 and x4.

    My setup:

    Panasonic Fz802 (4k OLED)
    PAL 50Hz (SNES, Megadrive, Amiga etc)

    I’ve tried various settings but never get a picture in x3 or x4 modes. Which is a real shame because the silly TV won’t display x2 mode in 4:3 unless I turn game mode off.

    Any pointers would be appreciated!

Viewing 15 posts - 136 through 150 (of 168 total)
  • You must be logged in to reply to this topic.